aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGravatar Yuchen Zeng <zyc@google.com>2016-10-28 15:41:58 -0700
committerGravatar Yuchen Zeng <zyc@google.com>2016-10-28 15:41:58 -0700
commitc76e9d3062ac1286735be77887f7c4be511d77df (patch)
tree830593ef736b724de6d63ef60aace2189259437b /setup.py
parente8d830930182f52c5381117746395b303099b5c2 (diff)
parent086e28d5f5eba09576c18cef075a3434de2caaa7 (diff)
Merge remote-tracking branch 'upstream/master' into cares_buildin
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 7 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 90c8bef5e8..15b6c0f473 100644
--- a/setup.py
+++ b/setup.py
@@ -85,6 +85,11 @@ BUILD_WITH_CYTHON = os.environ.get('GRPC_PYTHON_BUILD_WITH_CYTHON', False)
ENABLE_CYTHON_TRACING = os.environ.get(
'GRPC_PYTHON_ENABLE_CYTHON_TRACING', False)
+# Environment variable specifying whether or not there's interest in setting up
+# documentation building.
+ENABLE_DOCUMENTATION_BUILD = os.environ.get(
+ 'GRPC_PYTHON_ENABLE_DOCUMENTATION_BUILD', False)
+
# There are some situations (like on Windows) where CC, CFLAGS, and LDFLAGS are
# entirely ignored/dropped/forgotten by distutils and its Cygwin/MinGW support.
# We use these environment variables to thus get around that without locking
@@ -219,7 +224,8 @@ SETUP_REQUIRES = INSTALL_REQUIRES + (
'sphinx>=1.3',
'sphinx_rtd_theme>=0.1.8',
'six>=1.10',
-)
+ ) if ENABLE_DOCUMENTATION_BUILD else ()
+
if BUILD_WITH_CYTHON:
sys.stderr.write(
"You requested a Cython build via GRPC_PYTHON_BUILD_WITH_CYTHON, "