aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGravatar Masood Malekghassemi <atash@google.com>2016-07-11 15:10:02 -0700
committerGravatar Masood Malekghassemi <atash@google.com>2016-07-12 14:13:32 -0700
commitc3e3ae58629546329c05db1689281b40a0fcac6f (patch)
tree4b2f9aeeeb0fe40d3d1985b234bf712cf9986cca /setup.py
parent7126163b92c4b6be0ed8f9954e29fd9965cd7bb6 (diff)
Patch `spawn` for Python 'unix' compilers instead
Before we patched the link command, now we just patch `spawn` as an updatable catch-all solution to ARG_MAX limitations on bash for MSYS and MinGW and friends.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 700515b894..ac46035426 100644
--- a/setup.py
+++ b/setup.py
@@ -62,8 +62,8 @@ import commands
import grpc_core_dependencies
import grpc_version
-# TODO(atash) make this conditional on being on a mingw32 build
-_unixccompiler_patch.monkeypatch_unix_compiler()
+if 'win32' in sys.platform:
+ _unixccompiler_patch.monkeypatch_unix_compiler()
LICENSE = '3-clause BSD'