aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGravatar aaronjheng <wentworth@outlook.com>2016-08-29 12:02:48 +0800
committerGravatar aaronjheng <wentworth@outlook.com>2016-08-29 12:02:48 +0800
commitb273c04cd50bdd9880140e115ccbf6a12f63292a (patch)
treeddb05a2f56fb52937dd1d762e8e7622ff8deecc9 /setup.py
parent179e62467931c75a78a7528541760fa3e086e312 (diff)
remove futures from py3
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 096e8bdd4b..85da15241e 100644
--- a/setup.py
+++ b/setup.py
@@ -214,12 +214,14 @@ PACKAGE_DIRECTORIES = {
INSTALL_REQUIRES = (
'six>=1.5.2',
'enum34>=1.0.4',
- 'futures>=2.2.0',
# TODO(atash): eventually split the grpcio package into a metapackage
# depending on protobuf and the runtime component (independent of protobuf)
'protobuf>=3.0.0',
)
+if not PY3:
+ INSTALL_REQUIRES += ('futures>=2.2.0',)
+
SETUP_REQUIRES = INSTALL_REQUIRES + (
'sphinx>=1.3',
'sphinx_rtd_theme>=0.1.8',