aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGravatar Masood Malekghassemi <atash@google.com>2016-07-11 15:10:02 -0700
committerGravatar Masood Malekghassemi <atash@google.com>2016-07-16 00:05:02 -0700
commitb236279832e0064ec36d80c71766681f3ea335a6 (patch)
treeabbde2c771228368aa34f34d2c886dac6b952437 /setup.py
parent24ae8eaa8d60e7b3b13381179c217796e01b6697 (diff)
Patch `spawn` for Python 'unix' compilers instead
Before we patched the link command, now we just patch `spawn` as an updatable catch-all solution to ARG_MAX limitations on bash for MSYS and MinGW and friends.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 056e1fd033..28aa5a5c8e 100644
--- a/setup.py
+++ b/setup.py
@@ -62,8 +62,8 @@ import commands
import grpc_core_dependencies
import grpc_version
-# TODO(atash) make this conditional on being on a mingw32 build
-_unixccompiler_patch.monkeypatch_unix_compiler()
+if 'win32' in sys.platform:
+ _unixccompiler_patch.monkeypatch_unix_compiler()
LICENSE = '3-clause BSD'