aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGravatar Ken Payson <kpayson@google.com>2017-04-07 16:33:07 -0700
committerGravatar Ken Payson <kpayson@google.com>2017-04-07 16:33:07 -0700
commita0dacc3c4880a51dc3564a3c797ad91feb253295 (patch)
treea548af15704a41f25ca505c1db1d193b9366cd48 /setup.py
parent2035c2b48a00f13af4239e8be302d90737cd9657 (diff)
C++ build for python
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index e050646475..88dc54f8d0 100644
--- a/setup.py
+++ b/setup.py
@@ -102,7 +102,7 @@ ENABLE_DOCUMENTATION_BUILD = os.environ.get(
EXTRA_ENV_COMPILE_ARGS = os.environ.get('GRPC_PYTHON_CFLAGS', None)
EXTRA_ENV_LINK_ARGS = os.environ.get('GRPC_PYTHON_LDFLAGS', None)
if EXTRA_ENV_COMPILE_ARGS is None:
- EXTRA_ENV_COMPILE_ARGS = ''
+ EXTRA_ENV_COMPILE_ARGS = '-std=c++11'
if 'win32' in sys.platform and sys.version_info < (3, 5):
# We use define flags here and don't directly add to DEFINE_MACROS below to
# ensure that the expert user/builder has a way of turning it off (via the
@@ -195,6 +195,7 @@ def cython_extensions_and_necessity():
extensions = [
_extension.Extension(
name=module_name,
+ language='c++',
sources=[module_file] + list(CYTHON_HELPER_C_FILES) + list(CORE_C_FILES),
include_dirs=list(EXTENSION_INCLUDE_DIRECTORIES),
libraries=list(EXTENSION_LIBRARIES),