aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGravatar Ken Payson <kpayson@google.com>2017-07-25 12:06:46 -0700
committerGravatar Ken Payson <kpayson@google.com>2017-07-25 12:06:46 -0700
commit9c420447fa73d139748a483336a923fba1419e0a (patch)
tree7aedc352a1d246c2a19caf9ed4a137b5b67160ee /setup.py
parent196d3d6ee8778e1d08310cbb798d5500001ffdab (diff)
Add classifiers to package details
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py13
1 files changed, 13 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index e42c8342ea..403c13562c 100644
--- a/setup.py
+++ b/setup.py
@@ -60,6 +60,18 @@ _spawn_patch.monkeypatch_spawn()
LICENSE = 'Apache License 2.0'
+CLASSIFIERS = [
+ 'Development Status :: 5 - Production/Stable',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
+ 'License :: OSI Approved :: Apache Software License',
+],
+
# Environment variable to determine whether or not the Cython extension should
# *use* Cython or use the generated C files. Note that this requires the C files
# to have been generated by building first *with* Cython support. Even if this
@@ -283,6 +295,7 @@ setuptools.setup(
author_email='grpc-io@googlegroups.com',
url='https://grpc.io',
license=LICENSE,
+ classifiers=CLASSIFIERS,
long_description=open(README).read(),
ext_modules=CYTHON_EXTENSION_MODULES,
packages=list(PACKAGES),