aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGravatar Ken Payson <kpayson@google.com>2017-10-10 11:18:49 -0700
committerGravatar Ken Payson <kpayson@google.com>2017-10-12 10:22:48 -0700
commit9714e0376a2890b850496c981694af5f91a49353 (patch)
treeafa1e9b7fde0f7884b963b8380cbb07ecfbe136d /setup.py
parent70d6041739c45d741e61b7d45762400bed5903a8 (diff)
Add thread pool reset on fork with FORKING_SUPPORT_ENABLED
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 90c9316b0d..fcb5a1cf72 100644
--- a/setup.py
+++ b/setup.py
@@ -169,7 +169,7 @@ if "win32" in sys.platform:
# on msvc, but only for 32 bits
DEFINE_MACROS += (('NTDDI_VERSION', 0x06000000),)
else:
- DEFINE_MACROS += (('HAVE_CONFIG_H', 1),)
+ DEFINE_MACROS += (('HAVE_CONFIG_H', 1), ('GRPC_ENABLE_FORK_SUPPORT', 1),)
LDFLAGS = tuple(EXTRA_LINK_ARGS)
CFLAGS = tuple(EXTRA_COMPILE_ARGS)