aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGravatar Yuchen Zeng <zyc@google.com>2017-03-22 10:54:31 -0700
committerGravatar Yuchen Zeng <zyc@google.com>2017-03-22 10:54:31 -0700
commit937302b0df8d18f0cba94b2fd5f9804a138c0b3a (patch)
tree671f0b2df4a05551be02580c5b2c6444c0aa5ff3 /setup.py
parenteb799b78b3b260722a74bfcaa14b43ecaa9341ae (diff)
parentbe0dba162edf8a105a0e529f1e70e2b352137d4c (diff)
Merge remote-tracking branch 'upstream/master' into cares_rebase
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 5f27df097b..9a2edbf28f 100644
--- a/setup.py
+++ b/setup.py
@@ -216,14 +216,13 @@ PACKAGE_DIRECTORIES = {
INSTALL_REQUIRES = (
'six>=1.5.2',
- 'enum34>=1.0.4',
# TODO(atash): eventually split the grpcio package into a metapackage
# depending on protobuf and the runtime component (independent of protobuf)
'protobuf>=3.2.0',
)
if not PY3:
- INSTALL_REQUIRES += ('futures>=2.2.0',)
+ INSTALL_REQUIRES += ('futures>=2.2.0', 'enum34>=1.0.4')
SETUP_REQUIRES = INSTALL_REQUIRES + (
'sphinx>=1.3',