aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGravatar David Garcia Quintas <dgq@google.com>2018-06-04 13:49:15 -0700
committerGravatar David Garcia Quintas <dgq@google.com>2018-06-04 13:49:15 -0700
commit92ea033728e3fb81dcee6c16f27d69d66a6dc84a (patch)
treee0e644ddecc3e058bfac8656078daa1629c36ec4 /setup.py
parentbc9573d7ac02fbd4b2e3a6d9f68524583a737453 (diff)
fix python setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 99d1a1c504..dae30ee7c1 100644
--- a/setup.py
+++ b/setup.py
@@ -37,6 +37,7 @@ PYTHON_STEM = os.path.join('src', 'python', 'grpcio')
CORE_INCLUDE = ('include', '.',)
BORINGSSL_INCLUDE = (os.path.join('third_party', 'boringssl', 'include'),)
ZLIB_INCLUDE = (os.path.join('third_party', 'zlib'),)
+NANOPB_INCLUDE = (os.path.join('third_party', 'nanopb'),)
CARES_INCLUDE = (
os.path.join('third_party', 'cares'),
os.path.join('third_party', 'cares', 'cares'),)
@@ -150,7 +151,7 @@ if "win32" in sys.platform:
EXTENSION_INCLUDE_DIRECTORIES = (
(PYTHON_STEM,) + CORE_INCLUDE + BORINGSSL_INCLUDE + ZLIB_INCLUDE +
- CARES_INCLUDE + ADDRESS_SORTING_INCLUDE)
+ NANOPB_INCLUDE + CARES_INCLUDE + ADDRESS_SORTING_INCLUDE)
EXTENSION_LIBRARIES = ()
if "linux" in sys.platform: