aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGravatar Jonathan Moss <jmoss@commoncode.io>2018-08-03 15:15:52 +1000
committerGravatar Jonathan Moss <jmoss@commoncode.io>2018-08-03 15:15:52 +1000
commit6956daa41f4a9bda5d1f381cbf0f74bec6636019 (patch)
treeb98a0a933d4de9cf9a3a6dfff147aaa1a0f6977e /setup.py
parentadc6966e6c5e3e3a0bbaa94cb709c6001c6bce9f (diff)
adding python version environmental markers in the new style
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 388e629ec2..b87843f335 100644
--- a/setup.py
+++ b/setup.py
@@ -276,11 +276,11 @@ PACKAGE_DIRECTORIES = {
}
INSTALL_REQUIRES = (
- 'six>=1.5.2',
+ "six>=1.5.2",
+ "futures>=2.2.0 ; python_version<'3.2'",
+ "enum34>=1.0.4 ; python_version<'3.4'"
)
-if not PY3:
- INSTALL_REQUIRES += ('futures>=2.2.0', 'enum34>=1.0.4')
SETUP_REQUIRES = INSTALL_REQUIRES + (
'sphinx>=1.3',