aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGravatar Alexander Polcyn <apolcyn@google.com>2017-10-18 00:20:33 -0700
committerGravatar Alexander Polcyn <apolcyn@google.com>2018-03-20 23:51:19 -0700
commit690dde672a877083e29ee5af0b8252697aa48fa0 (patch)
treea801580cf12ad6655cd45e695c11a45ded9b67b5 /setup.py
parent8327acd9a23d80e979eb890b71a53966c3509a6d (diff)
Add address sorting submodule for use in c-ares wrapper
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 7c07c5614c..8e9f6e0940 100644
--- a/setup.py
+++ b/setup.py
@@ -48,6 +48,7 @@ if 'linux' in sys.platform:
CARES_INCLUDE += (os.path.join('third_party', 'cares', 'config_linux'),)
if 'openbsd' in sys.platform:
CARES_INCLUDE += (os.path.join('third_party', 'cares', 'config_openbsd'),)
+ADDRESS_SORTING_INCLUDE = (os.path.join('third_party', 'address_sorting'),)
README = os.path.join(PYTHON_STEM, 'README.rst')
# Ensure we're in the proper directory whether or not we're being used by pip.
@@ -149,7 +150,7 @@ if "win32" in sys.platform:
EXTENSION_INCLUDE_DIRECTORIES = (
(PYTHON_STEM,) + CORE_INCLUDE + BORINGSSL_INCLUDE + ZLIB_INCLUDE +
- CARES_INCLUDE)
+ CARES_INCLUDE + ADDRESS_SORTING_INCLUDE)
EXTENSION_LIBRARIES = ()
if "linux" in sys.platform: