aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGravatar Jan Tattermusch <jtattermusch@users.noreply.github.com>2016-03-23 14:43:35 -0700
committerGravatar Jan Tattermusch <jtattermusch@users.noreply.github.com>2016-03-23 14:43:35 -0700
commit68f5a3bd8293996766903b4ac717156105e6cbd1 (patch)
treeb14736719b349713e1f3219650f1975710268852 /setup.py
parent9a1fa344e743b800763d82469493d57f8e695d81 (diff)
parent554c7dd22f5be8abf8cd447270cec2a1e754631c (diff)
Merge pull request #5368 from leifurhauks/py3_test_compat
Python: py3 compatibility for test runner & loader
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index afa9872ff2..9634de0f83 100644
--- a/setup.py
+++ b/setup.py
@@ -111,7 +111,7 @@ if "linux" in sys.platform or "darwin" in sys.platform:
DEFINE_MACROS += (('PyMODINIT_FUNC', pymodinit),)
-def cython_extensions(package_names, module_names, extra_sources, include_dirs,
+def cython_extensions(module_names, extra_sources, include_dirs,
libraries, define_macros, build_with_cython=False):
# Set compiler directives linetrace argument only if we care about tracing;
# this is due to Cython having different behavior between linetrace being
@@ -144,7 +144,7 @@ def cython_extensions(package_names, module_names, extra_sources, include_dirs,
return extensions
CYTHON_EXTENSION_MODULES = cython_extensions(
- list(CYTHON_EXTENSION_PACKAGE_NAMES), list(CYTHON_EXTENSION_MODULE_NAMES),
+ list(CYTHON_EXTENSION_MODULE_NAMES),
list(CYTHON_HELPER_C_FILES) + list(CORE_C_FILES),
list(EXTENSION_INCLUDE_DIRECTORIES), list(EXTENSION_LIBRARIES),
list(DEFINE_MACROS), bool(BUILD_WITH_CYTHON))