aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGravatar Nicolas "Pixel" Noble <pixel@nobis-crew.org>2016-09-08 01:58:49 +0200
committerGravatar Nicolas "Pixel" Noble <pixel@nobis-crew.org>2016-09-08 01:58:49 +0200
commit5928bff0c7765766af2ea1ce8120317810eb4f8c (patch)
treeb6d74bcac7fb0c3e83d466a6b07660237b0c3d63 /setup.py
parent483f90b5da6765a05e7807a1a9a7e2f2d0484b28 (diff)
parent7a209ace0e6c3b67fcefdfd3a2e50620312ee3a2 (diff)
Merge branch 'v1.0.x' of https://github.com/grpc/grpc into manual-upmerge
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index f7280952fd..7a65698cbb 100644
--- a/setup.py
+++ b/setup.py
@@ -198,12 +198,14 @@ PACKAGE_DIRECTORIES = {
INSTALL_REQUIRES = (
'six>=1.5.2',
'enum34>=1.0.4',
- 'futures>=2.2.0',
# TODO(atash): eventually split the grpcio package into a metapackage
# depending on protobuf and the runtime component (independent of protobuf)
'protobuf>=3.0.0',
)
+if not PY3:
+ INSTALL_REQUIRES += ('futures>=2.2.0',)
+
SETUP_REQUIRES = INSTALL_REQUIRES + (
'sphinx>=1.3',
'sphinx_rtd_theme>=0.1.8',