aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGravatar kpayson64 <kpayson@google.com>2016-07-12 16:22:48 -0700
committerGravatar GitHub <noreply@github.com>2016-07-12 16:22:48 -0700
commit4faea6b56ce8dc5e8ff464d5d5bd0911c846b6db (patch)
tree5d70c9590473550947e347c86c903171d623a1b8 /setup.py
parent6b8a8e4a74fc83153a6fd3fbb7ec1ed2b288b4b4 (diff)
parentf17f0f6b071fe42f0d57e6b2f08d797bcbcad88a (diff)
Merge pull request #7290 from soltanmm/auto-cy
Fallback to generating files if not generated
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py22
1 files changed, 17 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 700515b894..4a91de0e88 100644
--- a/setup.py
+++ b/setup.py
@@ -70,7 +70,9 @@ LICENSE = '3-clause BSD'
# Environment variable to determine whether or not the Cython extension should
# *use* Cython or use the generated C files. Note that this requires the C files
-# to have been generated by building first *with* Cython support.
+# to have been generated by building first *with* Cython support. Even if this
+# is set to false, if the script detects that the generated `.c` file isn't
+# present, then it will still attempt to use Cython.
BUILD_WITH_CYTHON = os.environ.get('GRPC_PYTHON_BUILD_WITH_CYTHON', False)
# Environment variable to determine whether or not to enable coverage analysis
@@ -146,10 +148,20 @@ def cython_extensions(module_names, extra_sources, include_dirs,
if ENABLE_CYTHON_TRACING:
define_macros = define_macros + [('CYTHON_TRACE_NOGIL', 1)]
cython_compiler_directives['linetrace'] = True
- file_extension = 'pyx' if build_with_cython else 'c'
- module_files = [os.path.join(PYTHON_STEM,
- name.replace('.', '/') + '.' + file_extension)
- for name in module_names]
+ pyx_module_files = [os.path.join(PYTHON_STEM,
+ name.replace('.', '/') + '.pyx')
+ for name in module_names]
+ c_module_files = [os.path.join(PYTHON_STEM,
+ name.replace('.', '/') + '.c')
+ for name in module_names]
+ if not build_with_cython:
+ for module_file in c_module_files:
+ if not os.path.isfile(module_file):
+ sys.stderr.write('Cython-generated files are missing; '
+ 'forcing Cython build...\n')
+ build_with_cython = True
+ break
+ module_files = pyx_module_files if build_with_cython else c_module_files
extensions = [
_extension.Extension(
name=module_name,