aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGravatar Jonathan Moss <jmoss@common.io>2018-07-25 16:15:33 +1000
committerGravatar Jonathan Moss <jmoss@common.io>2018-07-25 16:27:11 +1000
commit2e4ab7a6e26db79a2e65d420543469bd415a99e9 (patch)
tree0ebb58aaca1644df304d1200f8605a0aaccd005b /setup.py
parentefed3ea831fbd2665c3c8eb1499450fd3e9365f5 (diff)
Switched to extra_requires for Python 2 specific requirements
Modern Python dependancy tooling as defined in PEP-508 should use environment markers for Python version specific requirements. This allows the `grpcio` package to work with dependancy resolvers like poetry
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 6 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 388e629ec2..b045f6d6c7 100644
--- a/setup.py
+++ b/setup.py
@@ -279,9 +279,6 @@ INSTALL_REQUIRES = (
'six>=1.5.2',
)
-if not PY3:
- INSTALL_REQUIRES += ('futures>=2.2.0', 'enum34>=1.0.4')
-
SETUP_REQUIRES = INSTALL_REQUIRES + (
'sphinx>=1.3',
'sphinx_rtd_theme>=0.1.8',
@@ -346,4 +343,10 @@ setuptools.setup(
install_requires=INSTALL_REQUIRES,
setup_requires=SETUP_REQUIRES,
cmdclass=COMMAND_CLASS,
+ extra_requires={
+ ':python_version < "3"': [
+ 'futures>=2.2.0',
+ 'enum34>=1.0.4'
+ ]
+ },
)