aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGravatar Masood Malekghassemi <soltanmm@users.noreply.github.com>2016-01-12 09:21:57 -0800
committerGravatar Masood Malekghassemi <soltanmm@users.noreply.github.com>2016-01-14 06:55:06 -0800
commit1d177817958efb72679c55c9ef2136d15c5d9636 (patch)
tree6ab68bdae3f43e8781dba6d5309b900231e95597 /setup.py
parent59994bcc3e7a3f16e9380b610aaf1f8afa08aa39 (diff)
Check compiler versions at Python setup time
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 3 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index 85434c92be..2eca48686c 100644
--- a/setup.py
+++ b/setup.py
@@ -81,15 +81,10 @@ EXTENSION_LIBRARIES = ()
if not "darwin" in sys.platform:
EXTENSION_LIBRARIES += ('rt',)
-EXTRA_COMPILE_ARGS = ()
-if not "win" in sys.platform:
- EXTRA_COMPILE_ARGS = ('-pthread',)
-
DEFINE_MACROS = (('OPENSSL_NO_ASM', 1),)
def cython_extensions(package_names, module_names, include_dirs, libraries,
- define_macros, extra_compile_args,
- build_with_cython=False):
+ define_macros, build_with_cython=False):
if ENABLE_CYTHON_TRACING:
define_macros = define_macros + [('CYTHON_TRACE_NOGIL', 1)]
file_extension = 'pyx' if build_with_cython else 'c'
@@ -101,7 +96,6 @@ def cython_extensions(package_names, module_names, include_dirs, libraries,
name=module_name,
sources=[module_file] + grpc_core_dependencies.CORE_SOURCE_FILES,
include_dirs=include_dirs, libraries=libraries,
- extra_compile_args=extra_compile_args,
define_macros=define_macros,
) for (module_name, module_file) in zip(module_names, module_files)
]
@@ -117,7 +111,7 @@ def cython_extensions(package_names, module_names, include_dirs, libraries,
CYTHON_EXTENSION_MODULES = cython_extensions(
list(CYTHON_EXTENSION_PACKAGE_NAMES), list(CYTHON_EXTENSION_MODULE_NAMES),
list(EXTENSION_INCLUDE_DIRECTORIES), list(EXTENSION_LIBRARIES),
- list(DEFINE_MACROS), list(EXTRA_COMPILE_ARGS), bool(BUILD_WITH_CYTHON))
+ list(DEFINE_MACROS), bool(BUILD_WITH_CYTHON))
PACKAGE_DIRECTORIES = {
'': PYTHON_STEM,
@@ -137,6 +131,7 @@ COMMAND_CLASS = {
'build_proto_modules': commands.BuildProtoModules,
'build_project_metadata': commands.BuildProjectMetadata,
'build_py': commands.BuildPy,
+ 'build_ext': commands.BuildExt,
'gather': commands.Gather,
'run_interop': commands.RunInterop,
}