aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGravatar Nicolas "Pixel" Noble <pixel@nobis-crew.org>2016-02-22 21:27:26 +0100
committerGravatar Nicolas "Pixel" Noble <pixel@nobis-crew.org>2016-02-22 21:30:14 +0100
commit1280fdb5741f459fbec6a8c73a92d1c4ada34849 (patch)
tree2a37423f3c656fdfe76e97e9664c8567d75a3333 /setup.py
parentf37adb9451330aa82b689e0b3283f20de491a306 (diff)
parent9f791595903b926e32b3d2ec5d959cfe1a3e1e78 (diff)
Merge branch 'master' into backport-merge
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 4 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 46ad75f5a4..cfb578e215 100644
--- a/setup.py
+++ b/setup.py
@@ -95,10 +95,10 @@ if "linux" in sys.platform:
if not "win32" in sys.platform:
EXTENSION_LIBRARIES += ('m',)
-DEFINE_MACROS = (('OPENSSL_NO_ASM', 1), ('_WIN32_WINNT', 0x600))
+DEFINE_MACROS = (('OPENSSL_NO_ASM', 1), ('_WIN32_WINNT', 0x600), ('GPR_BACKWARDS_COMPATIBILITY_MODE', 1),)
-CFLAGS = ()
LDFLAGS = ()
+CFLAGS = ()
if "linux" in sys.platform:
LDFLAGS += ('-Wl,-wrap,memcpy',)
if "linux" in sys.platform or "darwin" in sys.platform:
@@ -168,7 +168,7 @@ COMMAND_CLASS = {
}
# Ensure that package data is copied over before any commands have been run:
-credentials_dir = os.path.join(PYTHON_STEM, 'grpc/_adapter/credentials')
+credentials_dir = os.path.join(PYTHON_STEM, 'grpc/_cython/_credentials')
try:
os.mkdir(credentials_dir)
except OSError:
@@ -202,12 +202,10 @@ TEST_LOADER = 'tests:Loader'
TEST_RUNNER = 'tests:Runner'
PACKAGE_DATA = {
- 'grpc._adapter': [
- 'credentials/roots.pem'
- ],
# Binaries that may or may not be present in the final installation, but are
# mentioned here for completeness.
'grpc._cython': [
+ '_credentials/roots.pem',
'_windows/grpc_c.32.python',
'_windows/grpc_c.64.python',
],