aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGravatar Masood Malekghassemi <atash@google.com>2016-06-13 20:53:02 -0700
committerGravatar Masood Malekghassemi <atash@google.com>2016-07-08 12:36:15 -0700
commit06c857cb86586755ab5f01f1a8fecc614f23dffa (patch)
tree412b49eadcc257447ac21c2b5ca06a755eb3aba7 /setup.py
parent586e3835fe01257299a8573df3e7540e5778bc45 (diff)
Patch monkeypatch link function to work in Python3
The modified link command was originally taken from a Python 2.x distutils.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index c6d3da7299..700515b894 100644
--- a/setup.py
+++ b/setup.py
@@ -57,13 +57,13 @@ os.chdir(os.path.dirname(os.path.abspath(__file__)))
sys.path.insert(0, os.path.abspath(PYTHON_STEM))
# Break import-style to ensure we can actually find our in-repo dependencies.
-import build
+import _unixccompiler_patch
import commands
import grpc_core_dependencies
import grpc_version
# TODO(atash) make this conditional on being on a mingw32 build
-build.monkeypatch_unix_compiler()
+_unixccompiler_patch.monkeypatch_unix_compiler()
LICENSE = '3-clause BSD'