aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Muxi Yan <mxyan@google.com>2018-03-20 14:17:47 -0700
committerGravatar Muxi Yan <mxyan@google.com>2018-03-20 14:28:33 -0700
commitb94d68111dbdfd9101c97c4f1467c0933281c7b1 (patch)
treeaa6f72c408535ecfaa452778a22a9f66d54bc3d8 /CMakeLists.txt
parent7cc4bd80af10a0ad41b9f143cc8acf892e15607f (diff)
Add message size filter and deadline filter plugins
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ef95d111ae..c2bceca78c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1383,6 +1383,8 @@ add_library(grpc_cronet
src/core/lib/transport/transport.cc
src/core/lib/transport/transport_op_string.cc
src/core/lib/debug/trace.cc
+ src/core/ext/filters/deadline/deadline_filter.cc
+ src/core/ext/filters/message_size/message_size_filter.cc
src/core/ext/filters/load_reporting/server_load_reporting_filter.cc
src/core/ext/filters/load_reporting/server_load_reporting_plugin.cc
src/core/ext/transport/cronet/client/secure/cronet_channel_create.cc
@@ -1438,7 +1440,6 @@ add_library(grpc_cronet
src/core/ext/filters/client_channel/subchannel.cc
src/core/ext/filters/client_channel/subchannel_index.cc
src/core/ext/filters/client_channel/uri_parser.cc
- src/core/ext/filters/deadline/deadline_filter.cc
src/core/lib/http/httpcli_security_connector.cc
src/core/lib/security/context/security_context.cc
src/core/lib/security/credentials/alts/alts_credentials.cc