aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Moiz Haidry <mhaidry@google.com>2018-10-08 10:10:31 -0700
committerGravatar Moiz Haidry <mhaidry@google.com>2018-10-08 12:24:03 -0700
commitb4d5c7cee42154b0e24006287a93022ec605def0 (patch)
tree71fb6e0473ffec064193fd05397a3d2a49942aad /CMakeLists.txt
parent3c10c6d4144b677d51f1b12afc0e797cc0910276 (diff)
Benchmark test for callback unary gRPC
Every thread intitiates multiple RPCs. The Callback of the unary RPC then issues a new RPC and this goes until the benchmark shuts down. For shutdown the main thread waits on a conditional variable. After shutdown the callbacks increment a rpcs done variable and once the the rpcs done equate the the total number of outstanding rpcs, the last callback performing the increment operation also issues a signal to wake up the main thread. The mainthread process to join the other threads and perform cleanup
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 66799c456f..b80d99a5c3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5249,6 +5249,7 @@ add_library(qps
${_gRPC_PROTO_GENS_DIR}/src/proto/grpc/testing/worker_service.grpc.pb.h
test/cpp/qps/benchmark_config.cc
test/cpp/qps/client_async.cc
+ test/cpp/qps/client_callback.cc
test/cpp/qps/client_sync.cc
test/cpp/qps/driver.cc
test/cpp/qps/parse_json.cc