aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Yuchen Zeng <zyc@google.com>2016-07-11 15:31:19 -0700
committerGravatar Yuchen Zeng <zyc@google.com>2016-07-11 15:31:19 -0700
commit9710106b5c494965c6efbb5b92eeb5c1fcf6a90a (patch)
tree50e0c34caeffc9cb5a283afac246cba41068929b /CMakeLists.txt
parentf0ec5b673cc525502bec1c945d514b7f021d799c (diff)
parent20b1d58b0c4d44abc04af6c6467b7b217fe54915 (diff)
Merge remote-tracking branch 'upstream/master' into fix_mac_build
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9910bd330c..8ac4818312 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -58,6 +58,13 @@ if(NOT ZLIB_ROOT_DIR)
set(ZLIB_ROOT_DIR ${CMAKE_CURRENT_SOURCE_DIR}/third_party/zlib)
endif()
+# Building the protobuf tests require gmock what is not part of a standard protobuf checkout.
+# Disable them unless they are explicitly requested from the cmake command line (when we assume
+# gmock is downloaded to the right location inside protobuf).
+if(NOT protobuf_BUILD_TESTS)
+ set(protobuf_BUILD_TESTS OFF CACHE BOOL "Build protobuf tests")
+endif()
+
add_subdirectory(${BORINGSSL_ROOT_DIR} third_party/boringssl)
add_subdirectory(${PROTOBUF_ROOT_DIR}/cmake third_party/protobuf)
add_subdirectory(${ZLIB_ROOT_DIR} third_party/zlib)