aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Mark D. Roth <roth@google.com>2017-09-01 09:00:06 -0700
committerGravatar Mark D. Roth <roth@google.com>2017-09-01 09:00:06 -0700
commit764cf04a13958d72db5a22eb4bbb9370e00777f5 (patch)
tree28f265c5458bb537688a1e81535877e2926deb52 /CMakeLists.txt
parentc928cfee2b94a99747f97ff8c5fb09277a1352b7 (diff)
Revert "Revert "Implement call combiner""
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index efc33c0a6c..6f374ff947 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -967,6 +967,7 @@ add_library(grpc
src/core/lib/http/format_request.c
src/core/lib/http/httpcli.c
src/core/lib/http/parser.c
+ src/core/lib/iomgr/call_combiner.c
src/core/lib/iomgr/closure.c
src/core/lib/iomgr/combiner.c
src/core/lib/iomgr/endpoint.c
@@ -1318,6 +1319,7 @@ add_library(grpc_cronet
src/core/lib/http/format_request.c
src/core/lib/http/httpcli.c
src/core/lib/http/parser.c
+ src/core/lib/iomgr/call_combiner.c
src/core/lib/iomgr/closure.c
src/core/lib/iomgr/combiner.c
src/core/lib/iomgr/endpoint.c
@@ -1637,6 +1639,7 @@ add_library(grpc_test_util
src/core/lib/http/format_request.c
src/core/lib/http/httpcli.c
src/core/lib/http/parser.c
+ src/core/lib/iomgr/call_combiner.c
src/core/lib/iomgr/closure.c
src/core/lib/iomgr/combiner.c
src/core/lib/iomgr/endpoint.c
@@ -1900,6 +1903,7 @@ add_library(grpc_test_util_unsecure
src/core/lib/http/format_request.c
src/core/lib/http/httpcli.c
src/core/lib/http/parser.c
+ src/core/lib/iomgr/call_combiner.c
src/core/lib/iomgr/closure.c
src/core/lib/iomgr/combiner.c
src/core/lib/iomgr/endpoint.c
@@ -2149,6 +2153,7 @@ add_library(grpc_unsecure
src/core/lib/http/format_request.c
src/core/lib/http/httpcli.c
src/core/lib/http/parser.c
+ src/core/lib/iomgr/call_combiner.c
src/core/lib/iomgr/closure.c
src/core/lib/iomgr/combiner.c
src/core/lib/iomgr/endpoint.c
@@ -2850,6 +2855,7 @@ add_library(grpc++_cronet
src/core/lib/http/format_request.c
src/core/lib/http/httpcli.c
src/core/lib/http/parser.c
+ src/core/lib/iomgr/call_combiner.c
src/core/lib/iomgr/closure.c
src/core/lib/iomgr/combiner.c
src/core/lib/iomgr/endpoint.c