aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Vijay Pai <vpai@google.com>2018-03-02 21:13:28 -0800
committerGravatar GitHub <noreply@github.com>2018-03-02 21:13:28 -0800
commit6eae794c9f8f305a51274a79400124093ddc9354 (patch)
tree60db115fab3f37787ebb52cbec549d0b3d69d5c5 /CMakeLists.txt
parentf22dae6b917e1d31c1dff03c2cd3c253774ff90f (diff)
parent4013f0ccdac95064f74a4c96cbe43c6a98c6c0ba (diff)
Merge pull request #14459 from vjpai/2phase_thd
C++ize gpr_thread as grpc_core::Thread, make it 2-phase init (construct/Start)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 303a2f465f..ab4fa8a253 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -659,9 +659,6 @@ add_library(gpr
src/core/lib/gpr/sync.cc
src/core/lib/gpr/sync_posix.cc
src/core/lib/gpr/sync_windows.cc
- src/core/lib/gpr/thd.cc
- src/core/lib/gpr/thd_posix.cc
- src/core/lib/gpr/thd_windows.cc
src/core/lib/gpr/time.cc
src/core/lib/gpr/time_posix.cc
src/core/lib/gpr/time_precise.cc
@@ -671,6 +668,8 @@ add_library(gpr
src/core/lib/gpr/tmpfile_posix.cc
src/core/lib/gpr/tmpfile_windows.cc
src/core/lib/gpr/wrap_memcpy.cc
+ src/core/lib/gprpp/thd_posix.cc
+ src/core/lib/gprpp/thd_windows.cc
src/core/lib/profiling/basic_timers.cc
src/core/lib/profiling/stap_timers.cc
)
@@ -6284,7 +6283,7 @@ endif (gRPC_BUILD_TESTS)
if (gRPC_BUILD_TESTS)
add_executable(gpr_thd_test
- test/core/gpr/thd_test.cc
+ test/core/gprpp/thd_test.cc
)