aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Yang Gao <yangg@google.com>2017-08-24 15:47:33 -0700
committerGravatar GitHub <noreply@github.com>2017-08-24 15:47:33 -0700
commit2921e1ea7dbf423c3d17eea89363b63ae1adacae (patch)
treed0ad02e00fe5e7845b2efe003a41bb15c6b89a25 /CMakeLists.txt
parentf28955d40d199a31459388ca2770467509181290 (diff)
parenta79ada3bcc0eb4803cce840f8c2a1b1791ce2aba (diff)
Merge pull request #12282 from yang-g/sync_thd_refactor
Refactor sync/thd headers
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 01fe022407..a2c0a4618f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -867,6 +867,7 @@ foreach(_hdr
include/grpc/support/string_util.h
include/grpc/support/subprocess.h
include/grpc/support/sync.h
+ include/grpc/support/sync_custom.h
include/grpc/support/sync_generic.h
include/grpc/support/sync_posix.h
include/grpc/support/sync_windows.h
@@ -885,6 +886,7 @@ foreach(_hdr
include/grpc/impl/codegen/gpr_types.h
include/grpc/impl/codegen/port_platform.h
include/grpc/impl/codegen/sync.h
+ include/grpc/impl/codegen/sync_custom.h
include/grpc/impl/codegen/sync_generic.h
include/grpc/impl/codegen/sync_posix.h
include/grpc/impl/codegen/sync_windows.h
@@ -1260,6 +1262,7 @@ foreach(_hdr
include/grpc/impl/codegen/gpr_types.h
include/grpc/impl/codegen/port_platform.h
include/grpc/impl/codegen/sync.h
+ include/grpc/impl/codegen/sync_custom.h
include/grpc/impl/codegen/sync_generic.h
include/grpc/impl/codegen/sync_posix.h
include/grpc/impl/codegen/sync_windows.h
@@ -1566,6 +1569,7 @@ foreach(_hdr
include/grpc/impl/codegen/gpr_types.h
include/grpc/impl/codegen/port_platform.h
include/grpc/impl/codegen/sync.h
+ include/grpc/impl/codegen/sync_custom.h
include/grpc/impl/codegen/sync_generic.h
include/grpc/impl/codegen/sync_posix.h
include/grpc/impl/codegen/sync_windows.h
@@ -1842,6 +1846,7 @@ foreach(_hdr
include/grpc/impl/codegen/gpr_types.h
include/grpc/impl/codegen/port_platform.h
include/grpc/impl/codegen/sync.h
+ include/grpc/impl/codegen/sync_custom.h
include/grpc/impl/codegen/sync_generic.h
include/grpc/impl/codegen/sync_posix.h
include/grpc/impl/codegen/sync_windows.h
@@ -2102,6 +2107,7 @@ foreach(_hdr
include/grpc/impl/codegen/gpr_types.h
include/grpc/impl/codegen/port_platform.h
include/grpc/impl/codegen/sync.h
+ include/grpc/impl/codegen/sync_custom.h
include/grpc/impl/codegen/sync_generic.h
include/grpc/impl/codegen/sync_posix.h
include/grpc/impl/codegen/sync_windows.h
@@ -2397,6 +2403,7 @@ foreach(_hdr
include/grpc/impl/codegen/gpr_types.h
include/grpc/impl/codegen/port_platform.h
include/grpc/impl/codegen/sync.h
+ include/grpc/impl/codegen/sync_custom.h
include/grpc/impl/codegen/sync_generic.h
include/grpc/impl/codegen/sync_posix.h
include/grpc/impl/codegen/sync_windows.h
@@ -2661,6 +2668,7 @@ foreach(_hdr
include/grpc/support/string_util.h
include/grpc/support/subprocess.h
include/grpc/support/sync.h
+ include/grpc/support/sync_custom.h
include/grpc/support/sync_generic.h
include/grpc/support/sync_posix.h
include/grpc/support/sync_windows.h
@@ -2679,6 +2687,7 @@ foreach(_hdr
include/grpc/impl/codegen/gpr_types.h
include/grpc/impl/codegen/port_platform.h
include/grpc/impl/codegen/sync.h
+ include/grpc/impl/codegen/sync_custom.h
include/grpc/impl/codegen/sync_generic.h
include/grpc/impl/codegen/sync_posix.h
include/grpc/impl/codegen/sync_windows.h
@@ -3092,6 +3101,7 @@ foreach(_hdr
include/grpc/support/string_util.h
include/grpc/support/subprocess.h
include/grpc/support/sync.h
+ include/grpc/support/sync_custom.h
include/grpc/support/sync_generic.h
include/grpc/support/sync_posix.h
include/grpc/support/sync_windows.h
@@ -3110,6 +3120,7 @@ foreach(_hdr
include/grpc/impl/codegen/gpr_types.h
include/grpc/impl/codegen/port_platform.h
include/grpc/impl/codegen/sync.h
+ include/grpc/impl/codegen/sync_custom.h
include/grpc/impl/codegen/sync_generic.h
include/grpc/impl/codegen/sync_posix.h
include/grpc/impl/codegen/sync_windows.h
@@ -3547,6 +3558,7 @@ foreach(_hdr
include/grpc/impl/codegen/gpr_types.h
include/grpc/impl/codegen/port_platform.h
include/grpc/impl/codegen/sync.h
+ include/grpc/impl/codegen/sync_custom.h
include/grpc/impl/codegen/sync_generic.h
include/grpc/impl/codegen/sync_posix.h
include/grpc/impl/codegen/sync_windows.h
@@ -3686,6 +3698,7 @@ foreach(_hdr
include/grpc/impl/codegen/gpr_types.h
include/grpc/impl/codegen/port_platform.h
include/grpc/impl/codegen/sync.h
+ include/grpc/impl/codegen/sync_custom.h
include/grpc/impl/codegen/sync_generic.h
include/grpc/impl/codegen/sync_posix.h
include/grpc/impl/codegen/sync_windows.h
@@ -3839,6 +3852,7 @@ foreach(_hdr
include/grpc/support/string_util.h
include/grpc/support/subprocess.h
include/grpc/support/sync.h
+ include/grpc/support/sync_custom.h
include/grpc/support/sync_generic.h
include/grpc/support/sync_posix.h
include/grpc/support/sync_windows.h
@@ -3857,6 +3871,7 @@ foreach(_hdr
include/grpc/impl/codegen/gpr_types.h
include/grpc/impl/codegen/port_platform.h
include/grpc/impl/codegen/sync.h
+ include/grpc/impl/codegen/sync_custom.h
include/grpc/impl/codegen/sync_generic.h
include/grpc/impl/codegen/sync_posix.h
include/grpc/impl/codegen/sync_windows.h