aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Mark D. Roth <roth@google.com>2016-09-07 09:14:50 -0700
committerGravatar Mark D. Roth <roth@google.com>2016-09-07 09:14:50 -0700
commit164f0e926deba3a7d95a79be5aba25452d15d697 (patch)
tree95cbc72bcc07e304946fcec2941e5c72a5849768 /CMakeLists.txt
parent0209f675c44fc87f35cabd9c2ea623101e8e1cb0 (diff)
parent61a420e9966e0b628c710bd4c2db2409bc1cfad9 (diff)
Merge remote-tracking branch 'upstream/master' into http_connect
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 067ce597f0..f45f9ddac2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -192,6 +192,7 @@ add_library(gpr
src/core/lib/support/log_posix.c
src/core/lib/support/log_windows.c
src/core/lib/support/murmur_hash.c
+ src/core/lib/support/percent_encoding.c
src/core/lib/support/slice.c
src/core/lib/support/slice_buffer.c
src/core/lib/support/stack_lockfree.c
@@ -1753,6 +1754,30 @@ if (gRPC_INSTALL)
endif()
+add_executable(gen_percent_encoding_tables
+ tools/codegen/core/gen_percent_encoding_tables.c
+)
+
+target_include_directories(gen_percent_encoding_tables
+ PRIVATE ${CMAKE_CURRENT_SOURCE_DIR}
+ PRIVATE ${CMAKE_CURRENT_SOURCE_DIR}/include
+ PRIVATE ${BORINGSSL_ROOT_DIR}/include
+ PRIVATE ${PROTOBUF_ROOT_DIR}/src
+ PRIVATE ${ZLIB_ROOT_DIR}
+ PRIVATE ${CMAKE_CURRENT_BINARY_DIR}/third_party/zlib
+)
+
+
+
+if (gRPC_INSTALL)
+ install(TARGETS gen_percent_encoding_tables EXPORT gRPCTargets
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ )
+endif()
+
+
add_executable(grpc_create_jwt
test/core/security/create_jwt.c
)