summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog13
-rw-r--r--debian/control3
-rw-r--r--debian/tests/basics4
-rw-r--r--debian/tests/control4
4 files changed, 22 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 50e4973f1..7d1abbf67 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,14 @@
+git-annex (4.20130816) UNRELEASED; urgency=low
+
+ * Debian: Run the builtin test suite as an autopkgtest.
+ * Debian: Recommend ssh-askpass, which ssh will use when the assistant
+ is run w/o a tty. Closes: #719832
+ * sync, merge: Bug fix: Don't try to merge into master when in a bare repo.
+ * import: Add options to control handling of duplicate files:
+ --duplicate, --deduplicate, and --clean-duplicates
+
+ -- Joey Hess <joeyh@debian.org> Thu, 15 Aug 2013 15:47:52 +0200
+
git-annex (4.20130815) unstable; urgency=low
* assistant, watcher: .gitignore files and other git ignores are now
@@ -10,7 +21,7 @@ git-annex (4.20130815) unstable; urgency=low
* Windows: Fixed permissions problem that prevented removing files
from directory special remote. Directory special remotes now fully usable.
- -- Joey Hess <joeyh@debian.org> Thu, 15 Aug 2013 09:39:18 +0200
+ -- Joey Hess <joeyh@debian.org> Thu, 15 Aug 2013 10:14:33 +0200
git-annex (4.20130802) unstable; urgency=low
diff --git a/debian/control b/debian/control
index 49c0bde93..041584ba1 100644
--- a/debian/control
+++ b/debian/control
@@ -60,6 +60,7 @@ Maintainer: Joey Hess <joeyh@debian.org>
Standards-Version: 3.9.4
Vcs-Git: git://git.kitenet.net/git-annex
Homepage: http://git-annex.branchable.com/
+XS-Testsuite: autopkgtest
Package: git-annex
Architecture: any
@@ -70,7 +71,7 @@ Depends: ${misc:Depends}, ${shlibs:Depends},
wget,
curl,
openssh-client (>= 1:5.6p1)
-Recommends: lsof, gnupg, bind9-host
+Recommends: lsof, gnupg, bind9-host, ssh-askpass
Suggests: graphviz, bup, libnss-mdns
Description: manage files with git, without checking their contents into git
git-annex allows managing files with git, without checking the file
diff --git a/debian/tests/basics b/debian/tests/basics
new file mode 100644
index 000000000..2e4ea43fc
--- /dev/null
+++ b/debian/tests/basics
@@ -0,0 +1,4 @@
+#!/bin/sh
+testdir="$(mktemp -d)"
+cd "$testdir"
+exec git-annex test
diff --git a/debian/tests/control b/debian/tests/control
new file mode 100644
index 000000000..928caf8e3
--- /dev/null
+++ b/debian/tests/control
@@ -0,0 +1,4 @@
+Tests: basics
+Depends: @, git, rsync, gnupg
+Restrictions: allow-stderr
+