summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules13
1 files changed, 13 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index dab54a7b1..75254c079 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,3 +7,16 @@ export RELEASE_BUILD=1
%:
dh $@
+
+#
+# Rules for providing a standalone build of annex.
+#
+
+build-standalone:
+ [ -e .git ]
+ git checkout debian/changelog
+ quilt pop -a || :
+ QUILT_SERIES=series.standalone-build quilt push -a
+ debian/create-standalone-changelog
+ dpkg-buildpackage -rfakeroot
+ quilt pop -a