summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 3 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index 75254c079..0105f94db 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,14 +8,11 @@ export RELEASE_BUILD=1
%:
dh $@
-#
-# Rules for providing a standalone build of annex.
-#
-
+# Run this target to build git-annex-standalone.deb
build-standalone:
- [ -e .git ]
+ test -e .git
git checkout debian/changelog
- quilt pop -a || :
+ quilt pop -a || true
QUILT_SERIES=series.standalone-build quilt push -a
debian/create-standalone-changelog
dpkg-buildpackage -rfakeroot