summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorGravatar Joey Hess <joey@kitenet.net>2010-11-11 17:58:55 -0400
committerGravatar Joey Hess <joey@kitenet.net>2010-11-11 17:58:55 -0400
commitce62f5abf16e578f9f4b86cd140ea2ddfb1e4217 (patch)
treed50e4c639c2eb5a16ff292827378608f4ee6d68d /debian
parentb5ce88dd2aa2d6cc5eac6fd014f94d387c38bce0 (diff)
rework command dispatching for add and pre-commit
Both subcommands do two different operations on different sets of files, so allowing a subcommand to perform a list of operations cleans things up.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog8
1 files changed, 7 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index a4c8bceac..f705bfaf5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,12 @@
git-annex (0.05) UNRELEASED; urgency=low
- * Optimize both pre-commit and lock subcommands.
+ * Optimize both pre-commit and lock subcommands to not call git diff
+ on every file being committed or locked.
+ (This actually also works around a bug in ghc 6.12.1, that caused
+ git-annex 0.04 pre-commit to sometimes corrupt filenames and fail.
+ The excessive number of calls made by pre-commit exposed the ghc bug.
+ Thanks Josh Triplett for the debugging.)
+ * Build with -O3.
-- Joey Hess <joeyh@debian.org> Thu, 11 Nov 2010 14:52:05 -0400