summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorGravatar Joey Hess <joey@kitenet.net>2013-09-19 16:30:37 -0400
committerGravatar Joey Hess <joey@kitenet.net>2013-09-19 16:41:21 -0400
commit4aaa584eb632a981f5364c844f9293d4cdedaa65 (patch)
tree082addc10fa1a1554a616d54bb8e41d03e94c074 /debian
parent5fddb08efccedd5c1542f5e16ec63a57498bc1f0 (diff)
more completely solve catKey memory leak
Done using a mode witness, which ensures it's fixed everywhere. Fixing catFileKey was a bear, because git cat-file does not provide a nice way to query for the mode of a file and there is no other efficient way to do it. Oh, for libgit2.. Note that I am looking at tree objects from HEAD, rather than the index. Because I cat-file cannot show a tree object for the index. So this fix is technically incomplete. The only cases where it matters are: 1. A new large file has been directly staged in git, but not committed. 2. A file that was committed to HEAD as a symlink has been staged directly in the index. This could be fixed a lot better using libgit2.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 6cc20e412..ff374fd04 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -18,8 +18,8 @@ git-annex (4.20130912) UNRELEASED; urgency=low
numcopies levels. (--fast avoids calculating these)
* gcrypt: Ensure that signing key is set to one of the participants keys.
* webapp: Show encryption information when editing a remote.
- * sync, pre-commit, indirect: Avoid unnecessarily catting non-symlink
- files from git, which can be so large it runs out of memory.
+ * Avoid unnecessarily catting non-symlink files from git, which can be
+ so large it runs out of memory.
-- Joey Hess <joeyh@debian.org> Thu, 12 Sep 2013 12:14:46 -0400