summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorGravatar Joey Hess <joey@kitenet.net>2014-10-22 17:14:38 -0400
committerGravatar Joey Hess <joey@kitenet.net>2014-10-22 17:14:38 -0400
commit33e7dd2e0b756270cb51d1ed574cbe4b8173c7cd (patch)
tree0e9ff04c04c33cd1ba45171983d1b9f4d92cac60 /debian
parent2d7b57270e628994483495159d2be715c8f9531b (diff)
parent49475bb89542e92c6f466425f29cd0640a8e80f4 (diff)
Merge branch 'master' into s3-aws
Conflicts: Remote/S3.hs
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/cabal-wrapper20
-rw-r--r--debian/changelog63
-rw-r--r--debian/control25
-rw-r--r--debian/copyright4
-rwxr-xr-xdebian/rules3
5 files changed, 101 insertions, 14 deletions
diff --git a/debian/cabal-wrapper b/debian/cabal-wrapper
new file mode 100755
index 000000000..1326aead7
--- /dev/null
+++ b/debian/cabal-wrapper
@@ -0,0 +1,20 @@
+#!/bin/sh
+# It would be more usual to use:
+# export CABAL=./Setup
+# But Setup currently has a very bad dependency resolver, and very bad
+# debugging output, and tends to eat all memory and die on small buildds.
+#
+# This should be revisited once Debian has a newer ghc than 7.6.3,
+# and hopefully gets the improved dependency resolver from cabal.
+set -e
+
+# Avoid cabal writing to HOME, and avoid local cabal settings
+# influencing the build.
+HOME=$(mktemp -d)
+export HOME
+
+# Temporary workaround for #763078
+PATH=/usr/lib/llvm-3.4/bin:$PATH
+export PATH
+
+cabal "$@"
diff --git a/debian/changelog b/debian/changelog
index d0bff041d..c658ce186 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,62 @@
-git-annex (5.20140916) UNRELEASED; urgency=medium
-
+git-annex (5.20141014) UNRELEASED; urgency=medium
+
+ * vicfg: Deleting configurations now resets to the default, where
+ before it has no effect.
+ * Remove hurd stuff from cabal file, since hackage currently rejects
+ it, and the test suite fails on hurd.
+ * initremote: Don't allow creating a special remote that has the same
+ name as an existing git remote.
+ * Windows: Use haskell setenv library to clean up several ugly workarounds
+ for inability to manipulate the environment on windows. This includes
+ making git-annex not re-exec itself on start on windows, and making the
+ test suite on Windows run tests without forking.
+ * glacier: Fix pipe setup when calling glacier-cli to retrieve an object.
+ * info: When run on a single annexed file, displays some info about the
+ file, including its key and size.
+ * info: When passed the name or uuid of a remote, displays info about that
+ remote. Remotes that support encryption, chunking, or embedded
+ creds will include that in their info.
+ * enableremote: When the remote has creds, update the local creds cache
+ file. Before, the old version of the creds could be left there, and
+ would continue to be used.
+
+ -- Joey Hess <joeyh@debian.org> Tue, 14 Oct 2014 14:09:24 -0400
+
+git-annex (5.20141013) unstable; urgency=medium
+
+ * Adjust cabal file to support building w/o assistant on the hurd.
+ * Support building with yesod 1.4.
+ * S3: Fix embedcreds=yes handling for the Internet Archive.
+ * map: Handle .git prefixed remote repos. Closes: #614759
+ * repair: Prevent auto gc from happening when fetching from a remote.
+
+ -- Joey Hess <joeyh@debian.org> Mon, 13 Oct 2014 10:13:06 -0400
+
+git-annex (5.20140927) unstable; urgency=medium
+
+ * Really depend (not just build-depend) on new enough git for --no-gpg-sign
+ to work. Closes: #763057
+ * Add temporary workaround for bug #763078 which broke building on armel
+ and armhf.
+
+ -- Joey Hess <joeyh@debian.org> Sat, 27 Sep 2014 14:25:09 -0400
+
+git-annex (5.20140926) unstable; urgency=high
+
+ * Depend on new enough git for --no-gpg-sign to work. Closes: #762446
+ * Work around failure to build on mips by using cabal, not Setup,
+ to build in debian/rules.
+
+ -- Joey Hess <joeyh@debian.org> Fri, 26 Sep 2014 15:09:02 -0400
+
+git-annex (5.20140919) unstable; urgency=high
+
+ * Security fix for S3 and glacier when using embedcreds=yes with
+ encryption=pubkey or encryption=hybrid. CVE-2014-6274
+ The creds embedded in the git repo were *not* encrypted.
+ git-annex enableremote will warn when used on a remote that has
+ this problem. For details, see:
+ https://git-annex.branchable.com/upgrades/insecure_embedded_creds/
* assistant: Detect when repository has been deleted or moved, and
automatically shut down the assistant. Closes: #761261
* Windows: Avoid crashing trying to list gpg secret keys, for gcrypt
@@ -9,7 +66,7 @@ git-annex (5.20140916) UNRELEASED; urgency=medium
* add: In direct mode, adding an annex symlink will check it into git,
as was already done in indirect mode.
- -- Joey Hess <joeyh@debian.org> Mon, 15 Sep 2014 14:39:17 -0400
+ -- Joey Hess <joeyh@debian.org> Fri, 19 Sep 2014 12:53:42 -0400
git-annex (5.20140915) unstable; urgency=medium
diff --git a/debian/control b/debian/control
index fdd9e00be..659ec05fa 100644
--- a/debian/control
+++ b/debian/control
@@ -4,6 +4,7 @@ Priority: optional
Build-Depends:
debhelper (>= 9),
ghc (>= 7.4),
+ cabal-install,
libghc-mtl-dev (>= 2.1.1),
libghc-missingh-dev,
libghc-data-default-dev,
@@ -69,12 +70,13 @@ Build-Depends:
lsof [!kfreebsd-i386 !kfreebsd-amd64 !hurd-any],
ikiwiki,
perlmagick,
- git (>= 1:1.8.4),
+ git (>= 1:2.0),
rsync,
wget,
curl,
openssh-client,
git-remote-gcrypt (>= 0.20130908-6),
+ llvm-3.4 [armel armhf],
Maintainer: Joey Hess <joeyh@debian.org>
Standards-Version: 3.9.5
Vcs-Git: git://git.kitenet.net/git-annex
@@ -85,7 +87,7 @@ Package: git-annex
Architecture: any
Section: utils
Depends: ${misc:Depends}, ${shlibs:Depends},
- git (>= 1:1.8.4),
+ git (>= 1:2.0),
rsync,
wget,
curl,
@@ -108,10 +110,15 @@ Description: manage files with git, without checking their contents into git
dealing with files larger than git can currently easily handle, whether due
to limitations in memory, time, or disk space.
.
- Even without file content tracking, being able to manage files with git,
- move files around and delete files with versioned directory trees, and use
- branches and distributed clones, are all very handy reasons to use git. And
- annexed files can co-exist in the same git repository with regularly
- versioned files, which is convenient for maintaining documents, Makefiles,
- etc that are associated with annexed files but that benefit from full
- revision control.
+ It can store large files in many places, from local hard drives, to a
+ large number of cloud storage services, including S3, WebDAV,
+ and rsync, with a dozen cloud storage providers usable via plugins.
+ Files can be stored encrypted with gpg, so that the cloud storage
+ provider cannot see your data. git-annex keeps track of where each file
+ is stored, so it knows how many copies are available, and has many
+ facilities to ensure your data is preserved.
+ .
+ git-annex can also be used to keep a folder in sync between computers,
+ noticing when files are changed, and automatically committing them
+ to git and transferring them to other computers. The git-annex webapp
+ makes it easy to set up and use git-annex this way.
diff --git a/debian/copyright b/debian/copyright
index 19d61f228..84aec847f 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -28,6 +28,10 @@ Files: Utility/Gpg.hs Utility/DirWatcher*
Copyright: © 2010-2014 Joey Hess <joey@kitenet.net>
License: GPL-3+
+Files: Assistant/WebApp/Bootstrap3.hs
+Copyright: 2010 Michael Snoyman
+License: BSD-2-clause
+
Files: doc/logo* */favicon.ico standalone/osx/git-annex.app/Contents/Resources/git-annex.icns standalone/android/icons/*
Copyright: 2007 Henrik Nyh <http://henrik.nyh.se/>
2010 Joey Hess <joey@kitenet.net>
diff --git a/debian/rules b/debian/rules
index 3a0511fa6..7c8f8a560 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,6 @@
#!/usr/bin/make -f
-# Avoid using cabal, as it writes to $HOME
-export CABAL=./Setup
+export CABAL=debian/cabal-wrapper
# Do use the changelog's version number, rather than making one up.
export RELEASE_BUILD=1