summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorGravatar Joey Hess <joeyh@joeyh.name>2015-06-14 14:43:55 -0400
committerGravatar Joey Hess <joeyh@joeyh.name>2015-06-14 14:43:55 -0400
commit7a1adb83b0a102cc832a73c35c0b264b52cb88f5 (patch)
tree4e00e3cdaf64ef9d35d0c2f13c5982a5d599b46f /debian
parent5176de6b51413d8a379b0c647784e09f81d279d9 (diff)
debian/cabal-wrapper: Removed this hack which should not be needed anymore.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/cabal-wrapper20
-rw-r--r--debian/changelog1
-rw-r--r--debian/control1
-rwxr-xr-xdebian/rules3
4 files changed, 3 insertions, 22 deletions
diff --git a/debian/cabal-wrapper b/debian/cabal-wrapper
deleted file mode 100755
index 1326aead7..000000000
--- a/debian/cabal-wrapper
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/bin/sh
-# It would be more usual to use:
-# export CABAL=./Setup
-# But Setup currently has a very bad dependency resolver, and very bad
-# debugging output, and tends to eat all memory and die on small buildds.
-#
-# This should be revisited once Debian has a newer ghc than 7.6.3,
-# and hopefully gets the improved dependency resolver from cabal.
-set -e
-
-# Avoid cabal writing to HOME, and avoid local cabal settings
-# influencing the build.
-HOME=$(mktemp -d)
-export HOME
-
-# Temporary workaround for #763078
-PATH=/usr/lib/llvm-3.4/bin:$PATH
-export PATH
-
-cabal "$@"
diff --git a/debian/changelog b/debian/changelog
index f7757bfa0..2b2c464e3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -30,6 +30,7 @@ git-annex (5.20150529) UNRELEASED; urgency=medium
Fixes: unused, object count in info, unannex.
* Improve url parsing to handle some urls containing illegal []
characters in their paths.
+ * debian/cabal-wrapper: Removed this hack which should not be needed anymore.
-- Joey Hess <id@joeyh.name> Sat, 30 May 2015 02:07:18 -0400
diff --git a/debian/control b/debian/control
index ea532ca81..9fc8d2bc3 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,6 @@ Priority: optional
Build-Depends:
debhelper (>= 9),
ghc (>= 7.4),
- cabal-install,
libghc-mtl-dev (>= 2.1.1),
libghc-missingh-dev,
libghc-data-default-dev,
diff --git a/debian/rules b/debian/rules
index 927c1c925..d1393d571 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,6 +1,7 @@
#!/usr/bin/make -f
-export CABAL=debian/cabal-wrapper
+# Avoid using cabal, as it writes to $HOME
+export CABAL=./Setup
STANDALONE_BUILD=$(shell grep -qe '^Package: git-annex-standalone' debian/control \
&& echo 1 || echo 0)