summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorGravatar Joey Hess <joey@kitenet.net>2013-03-29 11:37:25 -0400
committerGravatar Joey Hess <joey@kitenet.net>2013-03-29 11:37:25 -0400
commit987b11fdf42b58a92d817131c416edbdbcb94297 (patch)
tree2ddd0165bd365d6428e3eb8707e8b7b7aa0f5942 /debian
parent3eaa9079161d010b330791581a74fc5de3701e25 (diff)
Build debian package without using cabal, which writes to HOME. Closes: #704205
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rw-r--r--debian/control1
-rwxr-xr-xdebian/rules3
3 files changed, 5 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 96cca734d..b8dbc7b2b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,8 @@ git-annex (4.20130324) UNRELEASED; urgency=low
* webapp: Fix a race that sometimes caused alerts or other notifications
to be missed if they occurred while a page was loading.
* webapp: Progess bar fixes for many types of special remotes.
+ * Build debian package without using cabal, which writes to HOME.
+ Closes: #704205
-- Joey Hess <joeyh@debian.org> Mon, 25 Mar 2013 10:21:46 -0400
diff --git a/debian/control b/debian/control
index be65a3973..c8a15ed80 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,6 @@ Priority: optional
Build-Depends:
debhelper (>= 9),
ghc (>= 7.4),
- cabal-install,
libghc-mtl-dev (>= 2.1.1),
libghc-missingh-dev,
libghc-hslogger-dev,
diff --git a/debian/rules b/debian/rules
index 7155baded..99bcd6aa0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,8 @@
#!/usr/bin/make -f
+# Avoid using cabal, as it writes to $HOME
+export CABAL=runghc Setup.hs
+
%:
dh $@