summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorGravatar Joey Hess <joeyh@joeyh.name>2016-03-01 15:31:39 -0400
committerGravatar Joey Hess <joeyh@joeyh.name>2016-03-01 15:31:39 -0400
commit59bb9730f6d245c2e917d048f2de3f5db3d00298 (patch)
treefe58da62730efc299bbc96d6f52af270c733f4dc /debian
parent784c3fa0139a5fc0ce459501d713cfe5c39d5a23 (diff)
Fix shared lock file FD leak.
This fixes behavior in this situation: l1 <- lockShared Nothing "lck" l2 <- lockShared Nothing "lck" dropLock l1 dropLock l2 Before, the lock was dropped upon the second dropLock call, but the fd remained open, and would never be closed while the program was running. Fixed by a rather round-about method, but it should work well enough. It would have been simpler to open open the shared lock once, and not open it again in the second call to lockShared. But, that's difficult to do atomically. This also affects Windows and PID locks, not just posix locks. In the case of pid locks, multiple calls to waitLock within the same process are allowed because the side lock is locked using a posix lock, and so multiple exclusive locks can be taken in the same process. So, this change fixes a similar problem with pid locks. l1 <- waitLock (Seconds 1) "lck" l2 <- waitLock (Seconds 1) "lck" dropLock l1 dropLock l2 Here the l2 side lock fd remained open but not locked, although the pid lock file was removed. After this change, the second dropLock will close both fds to the side lock, and delete the pidlock.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
1 files changed, 1 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index d15ca389b..2d7c24370 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,7 @@ git-annex (6.20160230) UNRELEASED; urgency=medium
* metadata: Added -r to remove all current values of a field.
* Fix data loss that can occur when annex.pidlock is set in a repository.
* Fix bug preventing moving files to/from a repository with annex.pidlock set.
+ * Fix shared lock file FD leak.
-- Joey Hess <id@joeyh.name> Mon, 29 Feb 2016 13:00:30 -0400