summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorGravatar Joey Hess <joeyh@joeyh.name>2015-01-20 16:58:48 -0400
committerGravatar Joey Hess <joeyh@joeyh.name>2015-01-20 17:09:24 -0400
commitc7e67aa29183c7fe7bb14b909cf953a89c531b08 (patch)
treee63f341fb51375faf9a0928af00703bcef584306 /debian
parent68c8b9b7592a7c407bdd6a0fe8b5f49241118926 (diff)
add getFileSize, which can get the real size of a large file on Windows
Avoid using fileSize which maxes out at just 2 gb on Windows. Instead, use hFileSize, which doesn't have a bounded size. Fixes support for files > 2 gb on Windows. Note that the InodeCache code only needs to compare a file size, so it doesn't matter it the file size wraps. So it has been left as-is. This was necessary both to avoid invalidating existing inode caches, and because the code passed FileStatus around and would have become more expensive if it called getFileSize. This commit was sponsored by Christian Dietrich.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog3
1 files changed, 3 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index bdbe2663d..eb48707f2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -13,6 +13,9 @@ git-annex (5.20150114) UNRELEASED; urgency=medium
* Fix wording of message displayed when unable to get a file that
is available in untrusted repositories.
* Windows: Fix running of the pre-commit-annex hook.
+ * Avoid using fileSize which maxes out at just 2 gb on Windows.
+ Instead, use hFileSize, which doesn't have a bounded size.
+ Fixes support for files > 2 gb on Windows.
-- Joey Hess <id@joeyh.name> Tue, 13 Jan 2015 17:03:39 -0400