summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorGravatar Joey Hess <joey@kitenet.net>2013-04-02 12:45:26 -0400
committerGravatar Joey Hess <joey@kitenet.net>2013-04-02 12:45:31 -0400
commit0af77809e07891bfec17813e4a3f4285f7cb17a4 (patch)
treeab3f738d8ceca1d33a420bf217244f328267ca93 /debian
parent973e1ad6bc463cad961373ed71351d3ccfede3fe (diff)
assistant: Fix bug that could cause direct mode files to be unstaged from git.
My test case for this bug is to have the assistant running and syncing to a remote, and create a file in the annex. Then at the command line run git annex drop. The assistant sees that the file is gone, sees it's a wanted file, and downloads it from the remote. With a directory special remote and a small file, I was seeing around 1 time in 3, a race where the file got unstaged from git after it got downloaded. Looking at what direct mode content managing code does in this case, it deletes the symlink, and then adds the file content back. It would be possible, sometimes, to avoid removing the symlink and do this atomically. And I probably should.. but in some cases, particularly where the file needs to be run through `cp` (multiple direct mode files with same content), there's no way to atomically replace the symlink with the content. Anyway, the bug turns out to be something that the watcher does right for indirect mode, but not for direct mode. When it got an add event, it checked to see if this was a new file, or one we've already added. In the latter case, no add event was queued. But that means that only the rm event is queued, and so it unstages the file. Fixed by queueing an add event even when the file is already in git. Tested by running hundreds of drops in a loop; file remained staged.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
1 files changed, 2 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 763e3577f..dc602e9e2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -24,6 +24,8 @@ git-annex (4.20130324) UNRELEASED; urgency=low
and unwanted repositories.
* drop --auto: Fix bug that prevented dropping files from untrusted
repositories.
+ * assistant: Fix bug that could cause direct mode files to be unstaged
+ from git.
-- Joey Hess <joeyh@debian.org> Mon, 25 Mar 2013 10:21:46 -0400