summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorGravatar Joey Hess <joey@kitenet.net>2013-01-27 09:30:53 +1100
committerGravatar Joey Hess <joey@kitenet.net>2013-01-27 09:30:53 +1100
commit3bd8fba2db932b7730ba497d60030db6ee6f6405 (patch)
treecae3c729ad258407c6f98505031c26c8a931e67f /debian
parent29af01f0a1b9851a9ead5d2286b23c57969e187c (diff)
addurl --fast: Use curl, rather than haskell HTTP library, to support https.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rw-r--r--debian/control1
-rwxr-xr-xdebian/rules4
3 files changed, 3 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 411f12a8c..df3021d69 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,7 @@ git-annex (3.20130125) UNRELEASED; urgency=low
* webapp: Now allows restarting any threads that crash.
* Adjust debian package to only build-depend on DAV on architectures
where it is available.
+ * addurl --fast: Use curl, rather than haskell HTTP library, to support https.
-- Joey Hess <joeyh@debian.org> Sat, 26 Jan 2013 15:48:40 +1100
diff --git a/debian/control b/debian/control
index cf25d65df..2610ca53b 100644
--- a/debian/control
+++ b/debian/control
@@ -10,7 +10,6 @@ Build-Depends:
libghc-pcre-light-dev,
libghc-sha-dev,
libghc-dataenc-dev,
- libghc-http-dev,
libghc-utf8-string-dev,
libghc-hs3-dev (>= 0.5.6),
libghc-dav-dev (>= 0.3) [amd64 i386 kfreebsd-amd64 kfreebsd-i386 sparc],
diff --git a/debian/rules b/debian/rules
index 8cd2b5aa5..1dd64872d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,9 +1,9 @@
#!/usr/bin/make -f
ifeq (install ok installed,$(shell dpkg-query -W -f '$${Status}' libghc-yesod-dev 2>/dev/null))
-export FEATURES=-DWITH_ASSISTANT -DWITH_S3 -DWITH_HOST -DWITH_OLD_URI -DWITH_PAIRING -DWITH_XMPP -DWITH_WEBAPP -DWITH_OLD_YESOD
+export FEATURES=-DWITH_ASSISTANT -DWITH_S3 -DWITH_HOST -DWITH_PAIRING -DWITH_XMPP -DWITH_WEBAPP -DWITH_OLD_YESOD
else
-export FEATURES=-DWITH_ASSISTANT -DWITH_S3 -DWITH_HOST -DWITH_OLD_URI -DWITH_PAIRING -DWITH_XMPP
+export FEATURES=-DWITH_ASSISTANT -DWITH_S3 -DWITH_HOST -DWITH_PAIRING -DWITH_XMPP
endif
ifeq (install ok installed,$(shell dpkg-query -W -f '$${Status}' libghc-dav-dev 2>/dev/null))
export FEATURES:=${FEATURES} -DWITH_WEBDAV