summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGravatar Yaroslav Halchenko <debian@onerussian.com>2015-04-20 11:29:32 -0400
committerGravatar Joey Hess <joeyh@joeyh.name>2015-04-20 14:46:34 -0400
commit99dead284006e9f32006be5515895de6660c527a (patch)
tree89089641f1c52cb4c346970bf6886beccd34d904 /debian/rules
parent914747670bafe9c5fd90d12cf5f887b46f02b00b (diff)
NF: provide debian/rules build-standalone
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules13
1 files changed, 13 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index dab54a7b1..75254c079 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,3 +7,16 @@ export RELEASE_BUILD=1
%:
dh $@
+
+#
+# Rules for providing a standalone build of annex.
+#
+
+build-standalone:
+ [ -e .git ]
+ git checkout debian/changelog
+ quilt pop -a || :
+ QUILT_SERIES=series.standalone-build quilt push -a
+ debian/create-standalone-changelog
+ dpkg-buildpackage -rfakeroot
+ quilt pop -a