summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGravatar Joey Hess <joey@kitenet.net>2012-09-29 01:28:02 -0400
committerGravatar Joey Hess <joey@kitenet.net>2012-09-29 01:28:02 -0400
commit6cdcae9e9acbc58feea5bf129b8f61e02f6f5940 (patch)
tree86846e990f2c3647329478d277b6291719af1903 /debian/rules
parent3753015a3533abdeccd979b2868f4fdbad001f53 (diff)
Avoid building the webapp on Debian architectures that do not yet have template haskell and thus yesod. (Should be available for arm soonish I hope).
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 6 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index aeb947054..c0fbd9aa4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,6 +1,11 @@
#!/usr/bin/make -f
-export GIT_ANNEX_LOCAL_FEATURES=-DWITH_OLD_YESOD
+ARCH = $(shell dpkg-architecture -qDEB_BUILD_ARCH)
+ifeq (install ok installed,$(shell dpkg-query -W -f '$${Status}' libghc-yesod-dev 2>/dev/null))
+export FEATURES=-DWITH_ASSISTANT -DWITH_S3 -DWITH_OLD_YESOD -DWITH_WEBAPP -DWITH_PAIRING
+else
+export FEATURES=-DWITH_ASSISTANT -DWITH_S3 -DWITH_PAIRING
+endif
%:
dh $@