summaryrefslogtreecommitdiff
path: root/debian/create-standalone-changelog
diff options
context:
space:
mode:
authorGravatar Joey Hess <joeyh@joeyh.name>2015-04-20 14:51:34 -0400
committerGravatar Joey Hess <joeyh@joeyh.name>2015-04-20 14:51:34 -0400
commita119c9daaba7d8bb67b265756e22b3f1ca117c5b (patch)
tree5d262bb263e61521a9f0ee35ec560aaef9ea7f41 /debian/create-standalone-changelog
parent99dead284006e9f32006be5515895de6660c527a (diff)
update to generate version in same format git-annex uses
Diffstat (limited to 'debian/create-standalone-changelog')
-rwxr-xr-xdebian/create-standalone-changelog7
1 files changed, 4 insertions, 3 deletions
diff --git a/debian/create-standalone-changelog b/debian/create-standalone-changelog
index 250673bdc..d1e5bbf5c 100755
--- a/debian/create-standalone-changelog
+++ b/debian/create-standalone-changelog
@@ -1,15 +1,16 @@
#!/bin/bash
#
# A little helper script to build a package with standalone git-annex
-# It relies on being run within git-annex Git repository
+# It relies on being run within git-annex's git repository
#
set -eu
umask 022
-git checkout debian/changelog
+# This is the same method that the configure script uses when git-annex is
+# built from git master.
+ANNEX_VERSION=$(git log -n 1 --format=format:'%ci %h'| sed -e 's/-//g' -e 's/ .* /-g/')
-ANNEX_VERSION=$(git describe HEAD)
ANNEX_NDVERSION=$( echo ${ANNEX_VERSION} | sed -e 's,-,+git,' -e 's,$,-1~ndall+1,')
dch --noconf -v ${ANNEX_NDVERSION} \