summaryrefslogtreecommitdiff
path: root/debian/create-standalone-changelog
diff options
context:
space:
mode:
authorGravatar Yaroslav Halchenko <debian@onerussian.com>2015-04-20 11:29:32 -0400
committerGravatar Joey Hess <joeyh@joeyh.name>2015-04-20 14:46:34 -0400
commit99dead284006e9f32006be5515895de6660c527a (patch)
tree89089641f1c52cb4c346970bf6886beccd34d904 /debian/create-standalone-changelog
parent914747670bafe9c5fd90d12cf5f887b46f02b00b (diff)
NF: provide debian/rules build-standalone
Diffstat (limited to 'debian/create-standalone-changelog')
-rwxr-xr-xdebian/create-standalone-changelog16
1 files changed, 16 insertions, 0 deletions
diff --git a/debian/create-standalone-changelog b/debian/create-standalone-changelog
new file mode 100755
index 000000000..250673bdc
--- /dev/null
+++ b/debian/create-standalone-changelog
@@ -0,0 +1,16 @@
+#!/bin/bash
+#
+# A little helper script to build a package with standalone git-annex
+# It relies on being run within git-annex Git repository
+#
+set -eu
+
+umask 022
+
+git checkout debian/changelog
+
+ANNEX_VERSION=$(git describe HEAD)
+ANNEX_NDVERSION=$( echo ${ANNEX_VERSION} | sed -e 's,-,+git,' -e 's,$,-1~ndall+1,')
+
+dch --noconf -v ${ANNEX_NDVERSION} \
+ --force-bad-version --force-distribution -D neurodebian "Backported fresh snapshot"