summaryrefslogtreecommitdiff
path: root/debian/changelog
diff options
context:
space:
mode:
authorGravatar Joey Hess <joey@kitenet.net>2011-04-19 15:26:50 -0400
committerGravatar Joey Hess <joey@kitenet.net>2011-04-19 15:27:03 -0400
commit5985acdfad8a6791f0b2fc54a1e116cee9c12479 (patch)
tree79bb1aa8ff55e4c53dc5ca08ea511aa6f9bd4232 /debian/changelog
parentb1274b637863ebb4e14d39ca2cf00a27c9d1f142 (diff)
bup: Avoid memory leak when transferring encrypted data.
This was a most surprising leak. It occurred in the process that is forked off to feed data to gpg. That process was passed a lazy ByteString of input, and ghc seemed to not GC the ByteString as it was lazily read and consumed, so memory slowly leaked as the file was read and passed through gpg to bup. To fix it, I simply changed the feeder to take an IO action that returns the lazy bytestring, and fed the result directly to hPut. AFAICS, this should change nothing WRT buffering. But somehow it makes ghc's GC do the right thing. Probably I triggered some weakness in ghc's GC (version 6.12.1). (Note that S3 still has this leak, and others too. Fixing it will involve another dance with the type system.) Update: One theory I have is that this has something to do with the forking of the feeder process. Perhaps, when the ByteString is produced before the fork, ghc decides it need to hold a pointer to the start of it, for some reason -- maybe it doesn't realize that it is only used in the forked process.
Diffstat (limited to 'debian/changelog')
-rw-r--r--debian/changelog3
1 files changed, 2 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 60ccace7a..4e9ea441d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,7 +3,8 @@ git-annex (0.20110418) UNRELEASED; urgency=low
* Don't run gpg in batch mode, so it can prompt for passphrase when
there is no agent.
* Add missing build dep on dataenc.
- * Fix stalls in S3 when transferring encrypted data.
+ * S3: Fix stalls when transferring encrypted data.
+ * bup: Avoid memory leak when transferring encrypted data.
-- Joey Hess <joeyh@debian.org> Sun, 17 Apr 2011 14:29:49 -0400