aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/third_party/abseil-cpp/absl/utility/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Firestore/third_party/abseil-cpp/absl/utility/CMakeLists.txt')
-rw-r--r--Firestore/third_party/abseil-cpp/absl/utility/CMakeLists.txt45
1 files changed, 45 insertions, 0 deletions
diff --git a/Firestore/third_party/abseil-cpp/absl/utility/CMakeLists.txt b/Firestore/third_party/abseil-cpp/absl/utility/CMakeLists.txt
new file mode 100644
index 0000000..df21b85
--- /dev/null
+++ b/Firestore/third_party/abseil-cpp/absl/utility/CMakeLists.txt
@@ -0,0 +1,45 @@
+#
+# Copyright 2017 The Abseil Authors.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+
+list(APPEND UTILITY_PUBLIC_HEADERS
+ "utility.h"
+)
+
+absl_header_library(
+ TARGET
+ absl_utility
+ EXPORT_NAME
+ utility
+)
+
+
+#
+## TESTS
+#
+
+# test utility_test
+set(UTILITY_TEST_SRC "utility_test.cc")
+set(UTILITY_TEST_PUBLIC_LIBRARIES absl::utility)
+
+absl_test(
+ TARGET
+ utility_test
+ SOURCES
+ ${UTILITY_TEST_SRC}
+ PUBLIC_LIBRARIES
+ ${UTILITY_TEST_PUBLIC_LIBRARIES}
+)