aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/core/test/firebase/firestore/remote/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Firestore/core/test/firebase/firestore/remote/CMakeLists.txt')
-rw-r--r--Firestore/core/test/firebase/firestore/remote/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/Firestore/core/test/firebase/firestore/remote/CMakeLists.txt b/Firestore/core/test/firebase/firestore/remote/CMakeLists.txt
index d42b107..1b4142a 100644
--- a/Firestore/core/test/firebase/firestore/remote/CMakeLists.txt
+++ b/Firestore/core/test/firebase/firestore/remote/CMakeLists.txt
@@ -18,5 +18,12 @@ cc_test(
datastore_test.cc
serializer_test.cc
DEPENDS
+ # NB: Order is important. We need to include the ffp_libprotobuf library
+ # before ff_remote, or else we'll end up with nanopb's headers earlier in
+ # the include path than libprotobuf's, which makes using libprotobuf in the
+ # test quite difficult. (protoc doesn't generate full include paths, so it
+ # includes files like this: `#include google/proto/timestamp.pb.h` which
+ # exists in both the libprotobuf path and the nanopb path.
+ firebase_firestore_protos_libprotobuf
firebase_firestore_remote
)