aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/core/src/firebase/firestore/util/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Firestore/core/src/firebase/firestore/util/CMakeLists.txt')
-rw-r--r--Firestore/core/src/firebase/firestore/util/CMakeLists.txt16
1 files changed, 5 insertions, 11 deletions
diff --git a/Firestore/core/src/firebase/firestore/util/CMakeLists.txt b/Firestore/core/src/firebase/firestore/util/CMakeLists.txt
index 043713f..30589a0 100644
--- a/Firestore/core/src/firebase/firestore/util/CMakeLists.txt
+++ b/Firestore/core/src/firebase/firestore/util/CMakeLists.txt
@@ -29,6 +29,7 @@ cc_library(
absl_strings
)
+
## assert and log
cc_library(
@@ -158,16 +159,6 @@ else()
endif()
-cc_library(
- firebase_firestore_util_async_queue
- SOURCES
- async_queue.cc
- async_queue.h
- DEPENDS
- ${FIREBASE_FIRESTORE_UTIL_EXECUTOR}
- ${FIREBASE_FIRESTORE_UTIL_LOG}
- EXCLUDE_FROM_ALL
-)
## main library
@@ -179,6 +170,8 @@ configure_file(
cc_library(
firebase_firestore_util
SOURCES
+ async_queue.cc
+ async_queue.h
autoid.cc
autoid.h
bits.cc
@@ -200,10 +193,11 @@ cc_library(
statusor_internals.h
string_util.cc
string_util.h
+ type_traits.h
DEPENDS
absl_base
firebase_firestore_util_base
- firebase_firestore_util_async_queue
+ ${FIREBASE_FIRESTORE_UTIL_EXECUTOR}
${FIREBASE_FIRESTORE_UTIL_LOG}
${FIREBASE_FIRESTORE_UTIL_RANDOM}
)