aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/Protos/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Firestore/Protos/CMakeLists.txt')
-rw-r--r--Firestore/Protos/CMakeLists.txt16
1 files changed, 8 insertions, 8 deletions
diff --git a/Firestore/Protos/CMakeLists.txt b/Firestore/Protos/CMakeLists.txt
index b347a61..fdf45e7 100644
--- a/Firestore/Protos/CMakeLists.txt
+++ b/Firestore/Protos/CMakeLists.txt
@@ -50,19 +50,19 @@ cc_library(
nanopb/google/type/latlng.pb.c
nanopb/google/type/latlng.nanopb.h
DEPENDS
- nanopb
+ protobuf-nanopb
)
target_compile_definitions(
- firebase_firestore_protos_nanopb PUBLIC
- -DPB_FIELD_16BIT
+ firebase_firestore_protos_nanopb
+ PUBLIC -DPB_FIELD_16BIT
)
# TODO(rsgowman): this may be worth moving into cc_library, possibly via an
# INCLUDE_DIRS or similar.
target_include_directories(
- firebase_firestore_protos_nanopb PUBLIC
- ${FIREBASE_SOURCE_DIR}/Firestore/Protos/nanopb
+ firebase_firestore_protos_nanopb
+ PUBLIC ${FIREBASE_SOURCE_DIR}/Firestore/Protos/nanopb
)
# libprotobuf based generated protos. Expected only to be used in test (as
@@ -102,10 +102,10 @@ cc_library(
target_include_directories(
firebase_firestore_protos_libprotobuf PUBLIC
- ${FIREBASE_SOURCE_DIR}/Firestore/Protos/cpp
+ ${FIREBASE_SOURCE_DIR}/Firestore/Protos/cpp
)
set_target_properties(
- firebase_firestore_protos_libprotobuf PROPERTIES
- COMPILE_FLAGS "-Wno-unused-parameter"
+ firebase_firestore_protos_libprotobuf
+ PROPERTIES COMPILE_FLAGS "-Wno-unused-parameter"
)