aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/third_party/abseil-cpp/absl/utility/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Marek Gilbert <mcg@google.com>2018-04-15 16:10:47 -0700
committerGravatar Marek Gilbert <mcg@google.com>2018-04-15 16:45:50 -0700
commitdfb5c04cf87fdff3c7fc16f9de3a2e8e1f4df265 (patch)
treed82fcc92ef0ba74169ae7d889a5e17c0541b262f /Firestore/third_party/abseil-cpp/absl/utility/CMakeLists.txt
parentc1061b7362471ddb7cae26c430f8112b0b94bb83 (diff)
Update abseil-cpp to a new upstream
Actually update to bf7fc9986e20f664958fc227547fd8d2fdcf863e Change #754 didn't completely do this. This makes the rest of the sources match optional, which was imported at this change in #1083. Also add: absl/types/optional_test.cc absl/types/CMakeLists.txt absl/utility/CMakeLists.txt
Diffstat (limited to 'Firestore/third_party/abseil-cpp/absl/utility/CMakeLists.txt')
-rw-r--r--Firestore/third_party/abseil-cpp/absl/utility/CMakeLists.txt45
1 files changed, 45 insertions, 0 deletions
diff --git a/Firestore/third_party/abseil-cpp/absl/utility/CMakeLists.txt b/Firestore/third_party/abseil-cpp/absl/utility/CMakeLists.txt
new file mode 100644
index 0000000..df21b85
--- /dev/null
+++ b/Firestore/third_party/abseil-cpp/absl/utility/CMakeLists.txt
@@ -0,0 +1,45 @@
+#
+# Copyright 2017 The Abseil Authors.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+
+list(APPEND UTILITY_PUBLIC_HEADERS
+ "utility.h"
+)
+
+absl_header_library(
+ TARGET
+ absl_utility
+ EXPORT_NAME
+ utility
+)
+
+
+#
+## TESTS
+#
+
+# test utility_test
+set(UTILITY_TEST_SRC "utility_test.cc")
+set(UTILITY_TEST_PUBLIC_LIBRARIES absl::utility)
+
+absl_test(
+ TARGET
+ utility_test
+ SOURCES
+ ${UTILITY_TEST_SRC}
+ PUBLIC_LIBRARIES
+ ${UTILITY_TEST_PUBLIC_LIBRARIES}
+)