aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/third_party/abseil-cpp/absl/memory/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Marek Gilbert <mcg@google.com>2018-02-06 09:43:55 -0800
committerGravatar Marek Gilbert <mcg@google.com>2018-02-06 10:06:42 -0800
commitef59c11f8291e8766ad4ac9dfceb9c6a8c80a173 (patch)
tree44aa0470b59a74c0836bf0cde42e31b646015466 /Firestore/third_party/abseil-cpp/absl/memory/CMakeLists.txt
parent53a125580d1cd656d3d824715aceb77e84ac5128 (diff)
parent582e4baf37cdfe23f17d4c6ca8fdd912108cfd29 (diff)
Merge branch 'abseil-mirror' into merge
Add StrCat, StrJoin and the rest of //strings from abseil-cpp (#756) From abseil-cpp version bf7fc9986e20f664958fc227547fd8d2fdcf863e
Diffstat (limited to 'Firestore/third_party/abseil-cpp/absl/memory/CMakeLists.txt')
-rw-r--r--Firestore/third_party/abseil-cpp/absl/memory/CMakeLists.txt52
1 files changed, 52 insertions, 0 deletions
diff --git a/Firestore/third_party/abseil-cpp/absl/memory/CMakeLists.txt b/Firestore/third_party/abseil-cpp/absl/memory/CMakeLists.txt
new file mode 100644
index 0000000..21bfc87
--- /dev/null
+++ b/Firestore/third_party/abseil-cpp/absl/memory/CMakeLists.txt
@@ -0,0 +1,52 @@
+#
+# Copyright 2017 The Abseil Authors.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+list(APPEND MEMORY_PUBLIC_HEADERS
+ "memory.h"
+)
+
+
+absl_header_library(
+ TARGET
+ absl_memory
+ EXPORT_NAME
+ memory
+)
+
+#
+## TESTS
+#
+
+# test memory_test
+list(APPEND MEMORY_TEST_SRC
+ "memory_test.cc"
+ ${MEMORY_PUBLIC_HEADERS}
+)
+set(MEMORY_TEST_PUBLIC_LIBRARIES absl::base absl::memory)
+
+
+
+absl_test(
+ TARGET
+ memory_test
+ SOURCES
+ ${MEMORY_TEST_SRC}
+ PUBLIC_LIBRARIES
+ ${MEMORY_TEST_PUBLIC_LIBRARIES}
+)
+
+
+