aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/third_party/abseil-cpp/absl/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Marek Gilbert <mcg@google.com>2017-12-06 09:10:24 -0800
committerGravatar Marek Gilbert <mcg@google.com>2017-12-07 13:02:52 -0800
commit58ff30b73fee4b87228506a8ca9ecb0e2602474e (patch)
tree03802e9d04d6d573018bb23764387971d77cd914 /Firestore/third_party/abseil-cpp/absl/CMakeLists.txt
parented26e832f60535229177cd0a0bdebd703e8c6dfb (diff)
Import a subset of abseil sources
Diffstat (limited to 'Firestore/third_party/abseil-cpp/absl/CMakeLists.txt')
-rw-r--r--Firestore/third_party/abseil-cpp/absl/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/Firestore/third_party/abseil-cpp/absl/CMakeLists.txt b/Firestore/third_party/abseil-cpp/absl/CMakeLists.txt
new file mode 100644
index 0000000..689f64e
--- /dev/null
+++ b/Firestore/third_party/abseil-cpp/absl/CMakeLists.txt
@@ -0,0 +1,30 @@
+#
+# Copyright 2017 The Abseil Authors.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+
+
+add_subdirectory(base)
+add_subdirectory(algorithm)
+add_subdirectory(container)
+add_subdirectory(debugging)
+add_subdirectory(memory)
+add_subdirectory(meta)
+add_subdirectory(numeric)
+add_subdirectory(strings)
+add_subdirectory(synchronization)
+add_subdirectory(time)
+add_subdirectory(types)
+add_subdirectory(utility)