aboutsummaryrefslogtreecommitdiffhomepage
path: root/Firestore/test/support/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gil <mcg@google.com>2017-11-20 20:53:08 -0800
committerGravatar GitHub <noreply@github.com>2017-11-20 20:53:08 -0800
commit5e49692058c62dc0eecbd09cca80720ad2976d0d (patch)
tree3896e8435f3f9445287ea22025842916c1d08df1 /Firestore/test/support/CMakeLists.txt
parent54aef651d82ebcc529498e4eba945a5512af4c95 (diff)
Add SecureRandom (#473)
* Add SecureRandom * Add CMake support for building src/support
Diffstat (limited to 'Firestore/test/support/CMakeLists.txt')
-rw-r--r--Firestore/test/support/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/Firestore/test/support/CMakeLists.txt b/Firestore/test/support/CMakeLists.txt
new file mode 100644
index 0000000..7de5367
--- /dev/null
+++ b/Firestore/test/support/CMakeLists.txt
@@ -0,0 +1,22 @@
+# Copyright 2017 Google
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+cc_test(
+ firestore_support_test
+ secure_random_test.cc
+)
+target_link_libraries(
+ firestore_support_test
+ firestore_support
+)